学习啦>学习电脑>电脑入门>《交换机命令行配置与VLAN介绍》正文

交换机命令行配置与VLAN介绍

学习啦【电脑入门】 志艺时间:2017-03-10 08:47:27我要投稿

  你还在为不知道交换机命令行配置与VLAN介绍而烦恼么?接下来是小编为大家收集的交换机命令行配置与VLAN介绍教程,希望能帮到大家。

  交换机命令行配置与VLAN介绍

  一、交换机配置方式

  1. 通过Console(控制台)端口连接终端或运行终端仿真软件的微机;第一次对交换机和路由器设置必须使用该方式。

  波特率:9600;数据位8;奇偶校验无;停止位1。

  2. 通过AUX端口连接MODEM,通过电话线与远方的终端或运行终端仿真软件的微机相连。

  3. 通过TFTP服务器。

  4. 通过TELNET程序。

  5. 通过SNMP网管工作站(如Cisco Works 2000)

  6. 此外,在交换机中启用HTTP服务,还可通过浏览器来配置。

  二、交换机、路由器的存储器和配置文件

  1、存储器分类

  1)RAM:随机存储器,相当于计算机的内存,掉电时所有信息都清空。用于保存交换机和路由器的运行数据,如路由表、ARP表、各端口运行状态等。

  2)ROM:只读存储器,用来存储系统引导软件和监控程序,其内容由厂商在出厂前固化,不能更改。

  3)NVRAM:非易失性可读写存储器,其特点是断电后内容不丢失。用来保存配置文件,启动时用这个配置文件作为初始化配置文件。

  4)Flash:闪存,它也是断电内容不丢失的存储器,用来存储交换机和路由器操作系统IOS,一般不修改,当升级IOS版本时可以修改。

  2、配置文件及其备份

  配置文件有两份:

  1)当前运行的配置(running-config):存储在RAM中的,可以修改,当关闭时,配置将全部丢失。

  2)备份配置(startup-config):存储在NVRAM中,每次启动时会自动装入。

  有以下几种备份方式:

  1)保存配置到NVRAM

  Switch#copy running-config startup-config

  2)保存配置到TFTP服务器中

  Switch#copy running-config tftp

  3)覆盖当前配置文件

  Switch#copy startup-config running-config

  Switch#config memory

  Switch#copy tftp running-config

  Switch#setup

  三、命令模式

  1、交换机的命令行(CLI)操作

  交换机和路由器的命令是按模式分组的,每种模式中都定义了一组命令集,所以想要使用某个命令,就必须先进入相应的模式。各种模式可通过命令提示符进行区分,命令提示符的格式为:

  提示符名 模式

  提示符名一般是设备的名字,交换机的默认名字为“Switch”,路由器的默认名字是“Router”,提示符模式表明了当前所处的模式。如:“>”代表用户模式,“#”代表特权模式。常见的几种命令模式如表2-1所示。

  表2-1 命令模式

模  式
访问方式示例
提示符
退出方法
用  途
User Exec
(用户模式)
进入命令行界面的第一个模式 Swich> 用 logout命令(qiut 命令在cisco中无效) 改变终端设备,执行基本测试,显示系统信息。
Privileged Exec
(特权模式)
Swich> enable Swich# 用disable 命令回到用户模式 校验输入的命令,该模式由密码保护。

Global Configuration
全局模配置式

Swich# configure terminal Switch(config)# 用exit 或 end 或 Ctrl+Z 回到特权模式 将配置的参数应用于整个交换机。
Config-vlan
VLAN配置模式
Switch(config)# Vlan 1 Switch(config-vlan)# 用 exit 命令回到特权模式;
用 end 或 Ctrl+Z 回到
用户模式
配置VLAN参数
VLAN-Configuration
VLAN数据模式
Switch# Vlan database Switch(vlan)# 用exit 或 end 或 Ctrl+Z 回到特权模式 在Vlan Database 中为VLAN1—1005 配置
VLAN 参数
Interface Configuration
接口配置模式
Switch(config)# Interface fastethnel 0/1 Switch(config-if)# 用 exit 命令回到特权模式;
用 end 或 Ctrl+Z 回到
用户模式
为接口配置参数
Line Configuration
线路配置模式
Switch(config)#line console 0 Switch(config-line)# 用 exit 命令回到特权模式;
用 end 或 Ctrl+Z 回到
用户模式

为线路配置参数

 

Router Configuration

路由配置模式

Switch(config)#router rip

Switch(config-router)# 用 exit 命令回到特权模式;
用 end 或 Ctrl+Z 回到
用户模式
为路由配置参数

  分为全局配置模式和vlan数据模式。全局配置模式又分为4个子模式:接口配置模式、线路配置模式、路由配置模式(不常用)、VLAN配置模式。

  2、 命令模式的切换交换机和路由器

  的模式大体可分为四层:用户模式→特权模式→全局配置模式→子配置模式。进入某模式时,需要逐层进入,如表2-2所示。

  表2-2 模式切换

要 求

举 例

进入用户模式

进入特权模式

Switch>enable

Switch #

进入全局配置模式

Switch #configure terminal
Switch (config)#

进入接口配置模式

Switch (config)#interface f0/1

Switch (config-if)#

进入线路配置模式

Switch (config)#line console 0

Switch (config-line)#

进入路由配置模式

Switch (config)#router rip

Switch (config-router)#

进入VLAN配置模式

Switch (config)#vlan 3

Switch (config-vlan)#

退回到特权模式

Switch (config-if)#exit
Switch (config)#

退回到用户模式

Switch #disable

Switch >

  注意:interface等命令都是带参数的命令,应根据情况使用不同参数。

  特例:当在特权模式下输入 Exit 命令时,会直接退出登录,而不是回到用户模式。从特权模式返回用户模式的命令是disable。

  3、CLI命令的编辑技巧

  CLI(命令行)有以下特点。

  l 命令不区分大小写。

  l 可以使用简写。命令中的每个单词只需要输入前几个字母。要求输入的字母个数足够与其他命令相区分即可。如:configure terminal命令可简写为conf t。

  l 用Tab键可简化命令的输入。如果你不喜欢简写的命令,可以用Tab键输入单词的剩余部分。每个单词只需要输入前几个字母,当它足够与其他命令相区分时,用Tab键可得到完整单词。如:输入conf(Tab) t(Tab)命令可得到configure terminal。

  l 可以调出历史来简化命令的输入。历史是指曾经输入过的命令,可以用“↑”键和“↓”键翻出历史命令再回车就可执行此命令(注:只能翻出当前提示符下的输入历史)。系统默认记录的历史条数是10条,用户可以用 history size 命令修改这个值。

  l 编辑快捷键。Ctrl+A——光标移到行首,Ctrl+E——光标移到行尾。

  l 用“?”可帮助输入命令和参数。在提示符下输入“?”可查看该提示符下的命令集,在命令后加“?”,可查看它的第一个参数,在参数后再加“?”,可查看下一个参数,如果遇到提示“<cr>”表示命令结束,可以回车了。

  四、交换机的基本配置

  1. 配置enable口令和交换机名称

  主机名用于标识交换机和路由器,通常它会作为提示符的一部分显示在命令提示符的前面。

  交换机的默认名字一般是“Switch”,路由器的默认名字一般是“Router”。可以用命令重新设置设备的名字。

  默认状态下,Cisco设备的Enable密码为空,所以,在对交换机进行初始配置时,必须为其设置Enable密码。

  有两种密码:secret密码以密文形式存在,使用128位的高级加密技术,目前没有破解此项技术的手法;password密码以明文形式存在。secret密码优先与password密码,即当两个密码都设定时,只有secret密码有效。

  不过可以使用service password-encryption对password密码、VTY密码等进行简单加密。

Switch>enable
Switch#configure terminal
Switch(config)#hostname SW2950
SW2950(config)#enable password cjj
SW2950(config)#enable secret cjj
SW2950(config)#service password-encryption
SW2950(config)#end
SW2950#copy running-config startup-config(或直接copy r s或cop r s)// 保存密码
SW2950#disable
SW2950>

  在全局配置模式下,用no hostname命令可删除配置的主机名,恢复默认值。

  2. 交换机接口配置的一般方法

  配置接口时,可以配置单个接口,也可以成组配置多个接口。这些接口划分VLAN时候才可以使用。

  这些端口可以配置双工模式、速率、端口描述、禁用端口等。

  1)接口可工作于半双工模式或全双工模式,默认情况下,它们用自协商方式确定其双工模式(auto/half/full)。用配置可指定它们只使用某一种双工模式。

  2)交换机接口都是具有多种速率的自适应接口,FastEthernet接口有10/100M两种速率,GigabitEthernet接口有10/100/1000M三种速率,默认情况下,它们用自协商方式确定它的工作速率。用配置可指定它们只使用某一个固定速率。

  3)使用description来描述端口的信息。

  4)交换机的所有接口默认是启用的,此时接口的状态为Up。如果禁用了一个接口,则该接口不能收发任何帧,此时接口的状态为Down。

switch(config)#int f0/1
switch(config-if)#duplex {auto/full/half}   // 可用no duplex 删除端口的双工模式,使其恢复到auto的默认模式
switch(config-if)#speed {10/100/1000/auto} // 可用no speed删除端口的工作速度,使其恢复到auto的工作速度
switch(config-if)#description 描述信息
switch(config-if)#shutdown // 管理性禁用某端口
switch(config-if)#no shutdown   // 重新启用某端口
switch(config-if)#end

  1) 配置单个接口

  命令:

  Switch(config)#interface port-ID

  Switch(config-if)#配置接口参数

  参数:port-ID是接口的标识,如f0/1(注意是从后面的编号是从1开始的),它可以是一个物理接口,也可以是一个VLAN(此时应该把VLAN理解为一个接口),或者是一个Aggregate Port(成组接口)。

  说明:interface命令可以在全局配置模式下执行,此时会进入接口配置模式,它也可以在接口配置模式下执行,所以配置完一个接口后,可直接用interface命令指定下一个接口。

  2) 成组配置接口

  如果有多个接口需要配置相同的参数时,可以成组配置这些接口。具体代码如下。

  Switch(config)#interface range port-range(range不可以少)

  Switch(config-if)#配置接口参数

  参数:port-range是接口的范围,它可以指定多个范围段,各范围段之间用逗号隔开。

  说明:port-range指定的接口范围可以是物理接口范围,也可以是一个VLAN范围。如:f0/1-6、vlan 2-4等。

  注意:在interface range中的接口必须是相同类型的接口。

  配置举例:配置交换机的接口fastethernet0/1~fastethernet0/12的速度为100Mbps,并把fastethernet0/1~fastethernet0/3和fastethernet0/7~fastethernet0/10分配给VLAN2。具体代码如下。

Switch>enable
Switch#configure terminal
Switch(config)#interface range f0/1-12
Switch(config-if)#speed 100
Switch(config-if)#interface range f0/1-3,0/7-10
Switch(config-if)#switchport access vlan 2
Switch(config-if)#end
Switch#

  3. 配置交换机ip地址、默认网关

  这些参数可以不用配置,配置目的是方便管理。注意:当交换机没有3层接口时,所有接口都属于VLAN1,所以VLAN1的IP地址就是交换机的IP地址。

Switch#config terminal
Switch(config)#ip default-gateway 192.168.4.1    // 设置默认网关<br>Switch(config)#ip name-server 192.168.1.1      // 设置域名服务器
Switch(config)#int vlan1
Switch(config-if)#ip address 192.168.4.100 255.255.255.0
Switch(config-if)#no shutdown            // 启用vlan1接口
Switch(config)#end
Switch#show r                      // 查看ip配置

  4. 配置和查看MAC地址表

  1)设置MAC地址表超时时间,缺省为300s

  Switch(config)#mac-address-table aging-time 100

  2)设置静态MAC地址:将MAC地址与端口对应起来,加入永久地址

  Switch(config)#mac-address-talbe permanent MAC地址 端口名称(即ip地址)

  Switch(config)#mac-address-talbe permanent 000.0c01.bbcc f0/3

  3)设置限制性静态地址:在永久地址的基础上,同时限制了源端口,其安全性更高

  Switch(config)#mac-address-table restricted static MAC地址 目标端口 源端口

  4)查看整个MAC地址表

  Switch(config)#show mac-address-talbe

  5)消除了限定性静态地址

  Switch(config)#clear mac-address restric static

  五、VLAN的概念

  划分VLAN的好处:对网络进行了分段,对广播进行了有效控制,增强了网络的灵活性和安全性。同一个VLAN中的端口处于一个广播域,处于不同VLAN的端口之间不能传递广播。划分VLAN后,不同VLAN中的端口的通讯被阻断了,因此必须依靠第三层设备(如路由器、三层交换机)来实现VLAN间的通讯。

  VLAN可以跨越多个交换机,交换机之间相连的端口必须设为Trunk模式。

  VLAN成员模式:静态VLAN(基于端口划分VLAN,最常用,具有更高安全性)和动态VLAN(基于MAC地址、基于网络层、基于策略)。

  VLAN标记:ISL(Cisco交换机专用的,VLAN最大值为1023,最多支持1024个)和IEEE 802.1q(4字节,最多4096个,2个被保留,可用4096个)。如果要在Cisco交换机和其他品牌的交换机之间建立Trunk连接,必须使用802.1q。

  1. 把当前端口access加入指定的VLAN

  access模式只能属于1个VLAN,一般用于接用户计算机的端口;在默认情况下,交换机所有接口都处于access模式,并且都属于VLAN1,并将VLAN作为管理VLAN。

Switch#configure terminal
Switch(config)#interface f0/1-16
Switch(config)#switchport mode access
Switch(config)#switchport access vlan 1 // 1的前面必须要有空格
Switch(config)#end
Switch#show interface f0/1 switchport

  需要注意的是,access端口加入的VLAN必须已经存在。

  2. 设置为trunk端口

configure terminal
interface f0/1
switchport mode {dynamic {auto | desirable} | trunk}
switchport trunk encapsulation { isl | dot1q }    // 指定数据帧封装形式
switchport trunk allowed vlan { add vlan-list | all |except vlan-list }
end
show interface f0/1 switchport

  dynamic auto 为自动协商;

  dynamic desirable :如果对方端口是trunk、desirable或auto,把端口设置为trunk;

  trunk:强制设置端口为trunk,而不理会对方端口是否为trunk。

  交换机的trunk接口默认情况下支持所有VLAN的传输。

  3. 还有一种为multi端口,很少用。

  六、VTP协议

  1、VTP:VLAN中继协议,Cisco专用协议,在一台交换机上添加、删除或者修改VLAN,然后同步到其他所有的交换机上,从而在整个网络上维持VLAN配置的移植性。VTP协议仅通过Trunk端口发送通告。

  2、VTP域:在一个VTP环境里,一台交换机可以是3种模式之一(服务器模式、客户机模式、透明模式)

  3、VTP通告:用VTP成员的同步VLAN配置消息。当VTP服务器修改VLAN信息,会把版本号加一,然后用新版本好发送新的配置信息。收到通告的交换机发现通告信息中的版本号比自己原有的版本号高,于是就用新收到的VLAN信息覆盖原有的配置信息。VTP通告以组播帧的形式发送。

  4、VTP修剪:缺省地,发给某个VLAN的广播被送到每一个在其某条干道链路(Trunk)上承载那个VLAN的交换机,即使交换机上没有位于那个VLAN的端口。这就意味着干道链路可能会传送最终将被该交换机扔掉的广播数据流。若启用VTP修剪,就可以限制广播、多点广播和泛滥的单点传送数据包通过没有端口属于那个VLAN的交换机,从而提高了干道链路(Trunk)带宽的利用率。

  在默认情况下,VTP修剪是被禁止的。如果在VTP Server上启用了VTP修剪,那么在整个VTP域就允许修剪。默认情况下,除了VLAN 1以外的VLAN都是可以修剪的,但VLAN 1作为管理VLAN是不允许修剪的。

  七、VTP配置与管理

  不推荐了,一些指令的用法也不一样了。

  1、VTP模式配置:

Switch#vlan database      // 进入vtp配置模式
Switch(vlan)#vtp server    // 配置交换机的工作状态,默认为server模式,可以使用vtp ?来查看帮助
Switch(vlan)#vtp domain cjj  // 配置vtp域的域名
Switch(vlan)#vtp password cjj // 为vtp域设置口令
Switch(vlan)#vtp pruning    // 启用VTP修剪功能,使用no关键字停止修剪功能
Switch(vlan)#exit        // 返回特权模式
Switch#show vtp status      // 验证VTP配置

  2、VLAN的创建:有两种方法

  1)在VTP域配置模式下创建VLAN

vlan database  // 进入vtp配置
vlan 2 name ypc  // 为vlan 2命名
vlan 2 mtu 1000  // 设置MTU大小
exit
show vlan id 2 // 或show vlan name ypc 或show vlan  

  最大传输单元(Maximum Transmission Unit,MTU)是指一种通信协议的某一层上面所能通过的最大数据包大小(以字节为单位)。最大传输单元这个参数通常与通信接口有关(网络接口卡、串口等)。

  2)在全局配置模式下创建VLAN

configure terminal
vlan 3
name cjj
mtu 3000
end
show vlan id 3

  八、生成树协议STP

  如果产生交换环路,会导致:广播风暴、多帧复制、MAC地址表抖动。

  交换机或者网桥之间周期性地发送STP的桥接协议数据单元(Bridge Protocol Data Unit ,BPDU),用于实现STP的功能。

  1)每2秒发送一次的二层报文

  2)组播发送,组播地址为:01-80-C2-00-00-00

  BPDU的传播过程:

  1)STP刚启动时,每台交换机都认为自己是根网桥,向外泛洪BPDU

  2)当交换机的一个端口收到高优先级的BPDU(更小的Root BID或者更小的Root Path Cost等等)就在该端口保存这些信息,同时向所有端口更新并传播信息

  3)如果收到比自己低优先级的BPDU,交换机就丢弃该信息

  BPDU传播的最终结果:

  1)网络中选择了一个交换机为根网桥(Root Bridge)

  2)每个交换机都计算到根网桥(Root Bridge)的最短路径

  3)除根网桥外的每个交换机都有一个根端口(Root Port),即提供最短路径到Root Bridge的端口

  4)每个LAN都有了指定交换机(Designated Bridge),位于该LAN与根交换机之间的最短路径中。指定交换机和LAN相连的端口称为指定端口(Designated port)

  5)根端口(Roor port)和指定端口(Designated port)进入转发Forwarding状态

  6)其他的冗余端口就处于阻塞状态(Blocking)

  STP的路径成本

  路径成本的计算和链路的带宽相关联,根路径成本就是到根网桥的路径中所有链路的路径成本的累计和,修订前后的802.1d路径成本 :

链路带宽

成本(修订前)

成本(修订后)

10G

1

2

1000M

1

4

100M

10

19

10M

100

100

  网桥ID

  用于选举根网桥:最低网桥ID的交换机将成为根网桥

  网桥优先级取值范围:0到65535;默认值:32768(0x8000)

  首先判断网桥优先级,优先级最低的网桥将成为根网桥

  如果网桥优先级相同,则比较网桥MAC地址,具有最低MAC地址的交换机或网桥将成为根网桥

  端口ID

  参与选举根端口

  端口优先级是从0到255的数字,默认值是128(0x80)

  端口优先级数值越小,则优先级越高

  如果端口优先级相同,则编号越小,优先级越高

  STP的端口状态

  1)阻塞状态(Blocking)

  不能接收或者传输数据,不能把MAC地址加入地址表,只能接收BPDU

  2)监听状态(Listening)

  不能接收或者传输数据,也不能把MAC地址加入地址表,但可以接收和发送BPDU

  3)学习状态(Learning)

  不能传输数据,但可以发送和接收BPDU,也可以学习MAC地址

  4)转发状态(Forwarding)

  能够发送和接收数据、学习MAC地址、发送和接收BPDU

  几个设置

  1)设置端口为快速端口,因为阻塞、监听的时间是不必要的。

  interface range f0/1-20

  spanning-tree portfast

  2)使用STP端口权值的负荷均衡:

  configure terminal

  interface f0/1

  spanning-tree vlan 8 port-priority 10

  默认端口权值为128的

  九、清空交换机所有配置

Switch#erase startup-config
Switch#delete vlan.dat
Switch#reload
 
 
Switch#delete flash:config.text
Switch#reload
 


看了“交换机命令行配置与VLAN介绍”还想看:

1.思科交换机配置命令教程

2.华为路由器交换机配置命令大全

3.Cisco常用的路由器交换机配置命令

4.h3c交换机配置命令详细解释

5.h3c交换机vlan配置命令

Copyright @ 2006 - 2017 学习啦 All Rights Reserved

学习啦 版权所有 粤ICP备15032933号-1

学习啦 学习啦

回到顶部