学习啦>学习电脑>电脑硬件知识>硬件知识>《华为s5700-SI交换机常用命令有哪些》正文

华为s5700-SI交换机常用命令有哪些

时间:2018-09-29 10:05:58本文内容及图片来源于读者投稿,如有侵权请联系xuexila888@qq.com 加城 我要投稿

  交换机的主要功能包括物理编址、网络拓扑结构、错误校验、帧序列以及流控。交换机还具备了一些新的功能,如对VLAN(虚拟局域网)的支持、对链路汇聚的支持,甚至有的还具有防火墙的功能。不同品牌交换机配置方法命令可能有所不同,但是大体思路都是一样的。这篇文章主要介绍了华为交换机常用命令以s5700-SI为例,需要的朋友可以参考下

华为s5700-SI交换机常用命令有哪些

  配置命令

  save // 配置完交换机后保存当前配置的命令

  system-view // 进入系统视图的命令

  clock timezone BJ add|minus 8 // 设置时区

  clock datetime 16:36:00 2016-07-01 //设置交换机的时间

  系统视图: 在用户视图下输入system-view后进入系统视图,一般为方括号[]

  display current-configuration // 显示当前配置

  user-interface maximum-vty 15 //配置vty最大连接数

  user-interface vty 0 14 //进入vty用户界面视图

  user privilege level 2 //设置vty登入的用户等级为2(配置用户级别)

  authentication-mode aaa //设置vty登入时的验证模式为用户名和密码验证

  aaa //进入AAA视图

  local-user admin password cipher admin@123 //设置aaa登入的用户名和密码

  local-user admin service-type telnet //设置admin用户远程登入时的协议

  user-interface console 0 //进入第0个console口的用户界面

  authentication-mode passwd //配置从console口登入交换机的认证模式为密码认证

  set authentication password cipher admin@123 //配置从console口登入交换机的密码

  vlan 10 //创建一个VLAN

  interface meth 0/0/1 //进入交换机的第一个管理网口

  ip address 192.168.1.110 24 //设置管理网口的ip地址和子网掩码

  interface gigabitethernet 0/0/1 //进入第一个业务网口

  port link-type access //设置第1个网口位access模式

  port default vlan 10 //设置此网口的VLAN号为10

  interface gigabitethnet 0/0/2 //进入第2个业务网口

  port link-type trunk //设置第二个网口位trunk模式

  port trunk allow-pass vlan 10 20 30 //设置此端口可以通过的VLAN号

  // port trunk allow-pass vlan all 表示可以通过所有的带VLAN的帧

  Interface gigabitethnet 0/0/3 //进入第3个业务网口

  Port link-type hybrid //设置此端口为hybrid模式,每个端口默认就是hybrid模式

  Port hybrid pvid vlan 10 //设置pvid为10

  Port hybrid tagged vlan 20 30 40 //设置tagged列表为20,30,40

  Port hybrid untagged vlan 50 60 //设置untagged列表为50,60

  Display port vlan //显示当前各端口的VLAN情况

  清除某个端口的配置

  Interface gigabitethernet 0/0/2

  Clear configuration this

  Undo shutdown

  Interface gigabitethernet 0/0/3

  Undo port default vlan //access 模式的端口

  Undo port link-type

  Undo port hybrid pvid vlan vlanid //hybrid 模式的端口

  Undo port hybrid untagged vlan vlanid

  Undo port hybrid tagged vlan vlanid

  Undo port trunk pvid vlan //trunk 模式的端口

  Undo port trunk allow-pass vlan vlanid

  Undo port link-type

  恢复出厂设置s5700SI

  在用户视图下(按Ctrl+z组合键回到用户视图)输入如下命令操作

  reset saved-configuration

  Y

  Reboot

  N

  Y

  设置交换机的mux-vlan模式

  假设主VLAN是10,从VLAN中group模式的有VLAN 20, separate模式的有VLAN 30,server连接1号端口,PC1和PC2连接2和3号端口,PC3和PC4连接4和5号端口

  Vlan batch 10 20 30

  Vlan 10

  Mux-vlan

  Subordinate group 20

  Subordinate separate 30

  把各连接的端口设为access模式,并且加入到各自的VLAN中,且同时开启mux-vlan功能,

  Interface gigabitethernet 0/0/1

  Port link-type access

  Port default vlan 10

  Port mux-vlan enable

  Interface gigabitethernet 0/0/2 //3号端口设置方法类似

  Port link-type access

  Port default vlan 20

  Port mux-vlan enable

  Interface gigabitethernet 0/0/4 //5号端口设置方法类似

  Port link-type access

  Port default vlan 30

  Port mux-vlan enable

  三层交换机接路由器LAN口

  Vlan 60 70

  Interface vlanif 60

  ip address 192.168.60.1 24

  interface vlanif 70

  ip address 192.168.1.238 24

  interface gigabitethernet 0/0/3

  port link-type access

  port default vlan 60

  interface gigabitethernet 0/0/4

  port link-type access

  port default vlan 70

  ip route-static 0.0.0.0 0.0.0.0 192.168.1.1

  在与交换机相连的路由器上设置一条静态ip地址,目的地址为交换机相关的各个网段地址,网关为交换机与路由器相连的vlanif的ip地址

  批量配置交换机端口

  vlan batch 10 20

  port-group 1

  group-member gigabitethernet 0/0/1 to gigabitethernet 0/0/10

  port link-type access

  port default vlan 10

  补充:交换机常见故障解决

  通过观察初步定为故障,一般如果设备正常,而且线路连接也正常,则交换机指示灯会亮绿色并且一闪一闪的。如果发现交换机指示灯不亮则首先检查线路连接,如果一直亮着不闪,则检查交换机等设备!

  通过电脑直接连接交换机查看是否能够自动获取IP地址和网关,如下面示意图连接电脑之后,将电脑TCP/IP协议设置为DHCP动态获取模式,然后运行命令行输入ipconfig查看电脑是否能够获取到交换机分配的ip地址和网关。

  如果交换机未配置,则需通过终端配置交换机,使用配置电缆的 DB-9 孔式插头接到要对交换机进行配置的 PC 或终端的串口上,将配置电缆的 RJ-45 一端连到交换机的配置口(Console)上。

  在 Console 口与本地电脑连接之后,在PC短通过终端与交换机建立连接,连接过程中要求,波特率为 9600,数据位为 8,奇偶校验为无,停止位为 1,流量控制为无,选择终端仿真为 VT100。

  通过超级终端登陆交换机之后,检查端口是否被shutdown,并通过display interface brief 命令,查看端口显示信息的速率与双工是否与对端一致。若不一致,请通过 speed 命令和 duplex 命令配置端口的速率和双工模式。

  (4)确认网线质量或光口的光模块类型及其波长是否匹配

  更换网线插入端口,查看端口是否 UP,端口物理连接是否畅通,端口是否被shutdown,检查端口连接,undo shutdown端口,检查网线是否正常。

  相关阅读:交换机的基本功能:

  1. 像集线器一样,交换机提供了大量可供线缆连接的端口,这样可以采用星型拓扑布线。

  2. 像中继器、集线器和网桥那样,当它转发帧时,交换机会重新产生一个不失真的方形电信号。

  3. 像网桥那样,交换机在每个端口上都使用相同的转发或过滤逻辑。

  4. 像网桥那样,交换机将局域网分为多个冲突域,每个冲突域都是有独立的宽带,因此大大提高了局域网的带宽。

  5. 除了具有网桥、集线器和中继器的功能以外,交换机还提供了更先进的功能,如虚拟局域网(VLAN)和更高的性能。


华为s5700-SI交换机常用命令相关文章:

1.华为交换机配置的命令有哪些

2.华为二层交换机基本配置命令有哪些

3.华为S5700交换机如何配置

4.华为交换机如何初始化配置

5.华为交换机路由器配置实例

Copyright @ 2006 - 2018 学习啦 All Rights Reserved

学习啦 版权所有 粤ICP备15032933号-1

我们采用的作品包括内容和图片全部来源于网络用户和读者投稿,我们不确定投稿用户享有完全著作权,根据《信息网络传播权保护条例》,如果侵犯了您的权利,请联系:xuexila888@qq.com,我站将及时删除。

学习啦 学习啦

回到顶部