学习啦>学习电脑>网络知识>路由器>路由器知识大全>《思科交换机配置命令有哪些》正文

思科交换机配置命令有哪些

时间:2018-09-17 17:25:42本文内容及图片来源于读者投稿,如有侵权请联系xuexila888@qq.com 加城 我要投稿

  cisco 还有全线的网络设备,包括集线器、交换机、访问服务器、软硬防火墙、网络管理软件等等。可能很多人不太熟悉思科交换机的配置,如果你在找这些命令可以阅读下文中提供的步骤,了解思科交换机配置命令有哪些。

思科交换机配置命令有哪些

  思科交换机配置方法:

  初始配置:

  1、给交换机通电;

  2、片刻后会看到交换机的启动信息,直到出现以下配置选项:

  Would you like to terminate autoinstall? [yes/no]: no

  Would you like to enter the initial configuration dialog? [yes/no]:no

  Would you like to terminate autoinstall? [yes/no]: no

  出现命令窗口:

  Switch>

  备份出厂配置:

  Switch>en 进入特权模式

  Switch#copy running-config sfbak-config

  Destination filename [sfbak-config]?回车

  片刻后会出现:

  1204 bytes copied in 0.529 secs (2276 bytes/sec)

  表示文件备份成功。

  配置账号密码:

  Switch#configure terminal 进入配置子模式

  Switch(config)#enable password cisco 设置PASSWORD密码为cisco

  Switch(config)#enable secret cisco 设置SECRET密码为cisco

  Switch(config)#exit

  片刻后会出现:

  00:11:26: %SYS-5-CONFIG_I: Configured from console by console

  表示将配置保存到了内存中,在后面的配置过程中会出现类似的信息,属于正常现象。

  创建VLAN:

  Switch#show vlan 查看VLAN信息,默认有一个VLAN 1,并且所有端口都属于它

  Switch#vlan database 进入VLAN子模式

  片刻后会出现:

  % Warning: It is recommended to configure VLAN from config mode,

  as VLAN database mode is being deprecated. Please consult user

  documentation for configuring VTP/VLAN in config mode.

  属于正常的警告信息。

  Switch(vlan)#vlan 2 创建VLAN2

  片刻后会出现:

  VLAN 2 added:

  Name: VLAN0002

  表示VLAN创建成功。

  Switch(vlan)#vlan 3 创建VLAN3

  Switch(vlan)#exit

  为VLAN设置IP地址:

  为VLAN2设置IP地址

  Switch#configure terminal 进入配置子模式

  Switch(config)#interface vlan 2 配置IP,VLAN2

  Switch(config-if)#ip address 133.37.125.5 255.255.255.0 设置交换机IP(具体IP请依照实际情况设置)

  Switch(config-if)#exit

  为VLAN3设置IP地址

  Switch(config)#interface vlan 3 配置IP,VLAN3

  Switch(config-if)#ip address 192.168.1.5 255.255.255.0 设置交换机IP(具体IP请依照实际情况设置)

  Switch(config-if)#exit

  为VLAN划分交换机接口:

  配置1-12号电口为VLAN2

  Switch(config)#interface range fastEthernet 0/1 - 12 进入F0/1 到 F0/12

  Switch(config-if)#Switchport mode access 设成静态VLAN访问模式

  Switch(config-if)#Switchport access vlan 2 将此口分给VLAN2

  Switch(config-if)#exit

  ===================

  配置13-24号电口为VLAN3

  Switch(config)#interface range fastEthernet 0/13 - 24 进入F0/13 到 F0/24

  Switch(config-if)#Switchport mode access 设成静态VLAN访问模式

  Switch(config-if)#Switchport access vlan 3 将此口分给VLAN3

  Switch(config-if)#exit

  ===================

  配置1号光口为VLAN-2

  Switch(config)#interface GigabitEthernet 0/1 进入G0/1

  Switch(config-if)#Switchport mode access 设成静态VLAN访问模式

  Switch(config-if)#Switchport access vlan 2 将此口分给VLAN2

  Switch(config-if)#exit

  ===================

  配置2号光口为VLAN-3

  Switch(config)#interface GigabitEthernet 0/2 进入G0/2

  Switch(config-if)#Switchport mode access 设成静态VLAN访问模式

  Switch(config-if)#Switchport access vlan 3 将此口分给VLAN3

  Switch(config-if)#exit

  Switch(config)#exit

  关闭VLAN1:

  Switch#configure terminal 进入配置子模式

  Switch(config)#interface vlan 1 配置VLAN1

  Switch(config-if)#shutdown 关闭VLAN1

  Switch(config-if)#exit

  Switch(config)#exit

  Switch#show interface fastethernet0/1 status 查看F0/1网口状态

  Switch#show interface fastethernet0/1 查看F0/1网口详细配置

  Switch#show running-config 查看全局配置

  配置默认网关:

  Switch#configure terminal 进入配置子模式

  Switch(config)#ip default-gateway 133.37.125.4

  Switch(config)#exit

  设置使可以远程telnet登陆:

  Switch#configure terminal 进入配置子模式

  Switch(config)#line vty 0 4

  Switch(config-line)#password cisco

  Switch(config-line)#login

  Switch(config-line)#exit

  Switch(config)#exit

  保存当前配置:

  Switch#copy running-config startup-config

  Destination filename [startup-config]?回车

  片刻后出现:

  Building configuration...

  [OK]

  表示当前配置保存成功。

  补充:路由器提速技巧

  重启

  重启后的路由器由于释放了系统资源,效率最优化,运行速度更快。我们重启路由器方式并不多,通过管理IP输入用户名和密码进入后台管理界面,然后点击重启路由,还有就是强拔电源,我们并不建议这种野蛮操作。一键重启功就像摁开关一样简单。

  扩大信号

  WIFI信号会随着距离长短渐渐衰弱,有时候就是一堵墙的距离,你在这头它却在那头就是不能愉快玩耍,不管你是乡下的小洋楼还是城里的大HOUSE,加装个路由器简单又实惠。360度无死用全覆盖。只需两步轻松实现。

  干掉蹭网的

  火热的蹭网软件,占用你的路由、你的网络、你的资源。而这一切就在不知不觉中进行。潜伏着的敌人,我要代表月亮消灭你。

  相关阅读:路由器常见问题原因分析

  1、验证电缆是否安全连接

  这可能听起来像一个没有脑子,但大部分用户们有时忘记检查最明显的解决方案,然后再转到更复杂的解决方案。有人可能意外地拉扯或踢了一根电缆,导致电缆拔掉或松动。所以应检查所有涉及的电缆,并确保它们已牢固连接。

  2、检查过热

  像任何其他电子设备一样,路由器可能会成为过热的牺牲品。这种过热可能会损坏路由器,或者使其不稳定。检查路由器的温度,看看它是多么热。如果过热的话,请确保气流充足。

  3、路由器摆放位置很重要

  如果你无法使用Wi-Fi,则需要尝试重新摆放路由器。应确保没有阻塞无线信号,特别是可能干扰的金属物体或设备,如微波炉和无线电话等。还应确保路由器的天线位于垂直方向而不是水平位置,因为垂直天线将提供最大的覆盖区域。

  4、更改无线信道

  如果居住附近是公寓大楼等路由器居多的位置,路由器会受到其他无线路由器在相同频道上信号的干扰。确定并更改所在地区的最佳信道,从而改善无线信号(如果有安卓设备,Wi-Fi 概观360这个手机app可以帮助你分析附近区域并找到最佳信道)。

  5、重新启动路由器

  路由器的功能虽然强大,但是经过长时间使用之后,路由器就会出现网络卡顿、延迟甚至是无法上网的情况,这时,对于一般用户而言,重启路由器是最简单的解决方法,大多数路由器上的重启过程很简单,拔下路由器的电源线,等待几秒钟,然后重新插入即可,入门级路由器内部缓存低,路由器在使用到一定时间后会造成缓存过高,这时候通过重启路由器达到释放缓存,从而解决网速慢的问题,但这种方式治标不治本,换新的无线路由器才是根本解决方法。

  6、将路由器重置为出厂默认设置

  如果配置发生严重问题,可能需要尝试将路由器重置为出厂默认设置。长按路由器背面的重置针孔按钮(具体细节将因路由器而异)。请记住,重置后,需重新设置无线网络名称和密码。

学习啦友链、商务、投稿、客服:QQ:3061683909 邮箱3061683909@qq.com

Copyright @ 2006 - 2020 学习啦 All Rights Reserved

学习啦 版权所有 粤ICP备15032933号-1

我们采用的作品包括内容和图片全部来源于网络用户和读者投稿,我们不确定投稿用户享有完全著作权,根据《信息网络传播权保护条例》,如果侵犯了您的权利,请联系:xuexila888@qq.com,我站将及时删除。

学习啦

回到顶部