TP-link 位置:首页>学习电脑>网络知识>路由器>路由器设置>TP-link>《TP-LINK WR703N OpenW…》正文

TP-LINK WR703N OpenWrt怎么刷机

学习啦【TP-link】 编辑:本达 发布时间:2016-09-13

  有时候我们使用TP-LINK WR703N,但有时候某种需要我们需要升级TP-LINK WR703N,下面是学习啦小编给大家整理的一些有关TP-LINK WR703N OpenWrt刷机教程,希望对大家有帮助!

  TP-LINK WR703N OpenWrt刷机教程

  1、下载安装

  访问WR703N在OpenWrt的Wiki页,然后在Flashing一节中找到下载链接:squashfs-factory.bin。

  进入路由器管理界面,出厂配置为192.168.1.1,用户名和密码均为admin,然后进入固件更新,选择下载的文件,然后更新。

  等待一段时间(~~2min),然后重启路由。

  P.S. 官方固件不带WebUI,所以需要对Linux系统较为熟悉,否则可以选择国内有人编译的带LuCI和中文支持的版本,Google即可。

  2、初始配置

  首先用一根网线将703N的Lan口和你电脑相连,电脑上设置为DHCP模式。然后运行cmd.exe

  输入telent 192.168.1.1

  成功后出现OpenWrt的欢迎界面:

  然后更改root密码:

  输入passwd

  更改root密码后dropbear(SSH 服务)就运行了,输入exit退出telent

  以后就可以通过ssh管理OpenWrt

  3、网络配置

  OpenWrt官方的固件是不带LuCl的,所以初始的网络设定需要在命令行下完成

  下载ssh连接工具putty

  输入192.168.1.1

  点击open,如果弹出什么窗口点是即可

  输入用户名root回车 然后输入你刚刚设定的密码

  然后用vi修改相关配置(不会用vim的同学悲剧了)。

  首先修改/etc/config/wireless文件

  输入vi /etc/config/wireless回车

  注释掉# option disabled 1

  进入此界面后按i进入修改模式,改成如图所示

  改好后按esc,然后输入:wq保存退出

  然后修改/etc/config/network文件。

  首先修改lan接口配置,注释掉此行:

  # option ifname 'eth0'

  然后增加wan接口,如果你上级网络是DHCP的,则文件的末尾添加:

  config interface 'wan'

  option ifname 'eth0'

  option proto 'dhcp'

  如果你上级网络是静态IP,则在文件的末尾添加:

  config interface 'wan'

  option ifname 'eth0'

  option proto 'static'

  option ipaddr '10.22.33.124'

  option netmask '255.255.255.0'

  option gateway '10.22.33.1'

  option dns '202.113.16.10'

  此图为修改为静态ip模式,然后将路由器的Lan/Wan口接到上级网络中,重启路由器。这时便可以通过电脑寻找SSID为 OpenWrt的无线网络,加入后电脑便可以通过703N上网了。

 

看了“TP-LINK WR703N OpenWrt怎么刷机”的人还看了

1.以太网路由怎么上网fast

2.tplink app 怎么用

3.tplink怎么拿手机app设置

4.tplink+app怎么添加设备

5.tp无线路由器tr961怎么手机快速设置

6.TP-link怎么设置IP与MAC地址绑定

7.tplink pocket怎么设置

8.tplink路由器wdr7500怎么升级

9.tp link路由怎么登录tplink id

 

本文已影响
网友评论

Copyright © 2006 - 2016 XUEXILA.COM All Rights Reserved

学习啦 版权所有